Saturday, June 26, 2010

10.3.1 Scripts

hostname R1
no ip domain-lookup
enable password cisco
enable secret cisco
banner motd #Welcome to Router R1#
line console 0
password cisco
login
line vty 0
enable password cisco
login
int s0/0/0
ip add 10.1.64.1 255.255.255.252
no shutdown
clock rate 64000
int s0/0/1
ip add 10.1.64.5 255.255.255.252
no shutdown
clock rate 64000
int s0/1/0
ip add 10.1.64.9 255.255.255.252
no shutdown
clock rate 64000
int s0/1/1
ip add 209.165.201.2 255.255.255.252
no shutdown
clock rate 64000
router eigrp 1
no auto-summary
default-information originate
passive-interface s0/1/1
network 10.1.0.0
ip route 0.0.0.0 0.0.0.0 s0/1/1
end
copy running-config startup-config
startup-config
reload
y


hostname R2
no ip domain-lookup
enable password cisco
enable secret cisco
banner motd #Welcome to Router R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int s0/0/0
ip add 172.20.4.1 255.255.255.252
no shutdown
clock rate 64000
int s0/0/1
ip add 172.20.4.5 255.255.255.252
no shutdown
clock rate 64000
int s0/1/0
ip add 172.20.4.9 255.255.255.252
no shutdown
clock rate 64000
int s0/1/1
ip add 209.165.201.10 255.255.255.252
no shutdown
clock rate 64000
router rip
version 2
default-information originate
passive-interface s0/1/1
network 172.20.0.0
ip route 0.0.0.0 0.0.0.0 s0/1/1
end
copy running-config startup-config
startup-config
reload
y



hostname B1-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B1-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.0.1 255.255.248.0
no shutdown
int fa0/1
ip add 10.1.8.1 255.255.248.0
no shutdown
int fa1/0
ip add 10.1.16.1 255.255.248.0
no shutdown
int fa1/1
ip add 10.1.24.1 255.255.248.0
no shutdown
int s0/0/0
ip add 10.1.64.2 255.255.255.252
no shutdown
clock rate 64000
ip hello-interval eigrp 1 30
ip summary-address eigrp 1 10.1.0.0 255.255.224.0
router eigrp 1
no auto-summary
network 10.1.0.0
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
ip route 0.0.0.0 0.0.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y



hostname B2-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B2-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.32.1 255.255.252.0
no shutdown
int fa0/1
ip add 10.1.36.1 255.255.252.0
no shutdown
int fa1/0
ip add 10.1.40.1 255.255.252.0
no shutdown
int fa1/1
ip add 10.1.44.1 255.255.252.0
no shutdown
int s0/0/0
ip add 10.1.64.6 255.255.255.252
no shutdown
clock rate 64000
ip hello-interval eigrp 1 30
ip summary-address eigrp 1 10.1.32.0 255.255.240.0
router eigrp 1
no auto-summary
network 10.1.248.2
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
ip route 0.0.0.0 0.0.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y


hostname B3-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B3-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.48.1 255.255.254.0
no shutdown
int fa0/1
ip add 10.1.50.1 255.255.254.0
no shutdown
int fa1/0
ip add 10.1.52.1 255.255.254.0
no shutdown
int fa1/1
ip add 10.1.54.1 255.255.254.0
no shutdown
int s0/0/0
ip add 10.1.64.10 255.255.255.252
no shutdown
clock rate 64000
ip hello-interval eigrp 1 30
ip summary-address eigrp 1 10.1.48.0 255.255.248.0
router eigrp 1
no auto-summary
network 10.1.252.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
ip route 0.0.0.0 0.0.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y







hostname B1-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B1-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.0.1 255.255.255.128
no shutdown
int fa0/1
ip add 172.20.0.129 255.255.255.128
no shutdown
int fa1/0
ip add 172.20.1.1 255.255.255.128
no shutdown
int fa1/1
ip add 172.20.1.129 255.255.255.128
no shutdown
int s0/0/0
ip add 172.20.4.2 255.255.255.252
no shutdown
clock rate 64000
router rip
version 2
no auto-summary
network 172.20.250.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y


hostname B2-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B2-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.2.1 255.255.255.192
no shutdown
int fa0/1
ip add 172.20.2.65 255.255.255.192
no shutdown
int fa1/0
ip add 172.20.2.129 255.255.255.192
no shutdown
int fa1/1
ip add 172.20.2.193 255.255.255.192
no shutdown
int s0/0/0
ip add 172.20.4.6 255.255.255.252
no shutdown
clock rate 64000
router rip
version 2
no auto-summary
network 172.20.252.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y






hostname B3-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B3-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.3.1 255.255.255.224
no shutdown
int fa0/1
ip add 172.20.3.33 255.255.255.224
no shutdown
int fa1/0
ip add 172.20.3.65 255.255.255.224
no shutdown
int fa1/1
ip add 172.20.3.97 255.255.255.224
no shutdown
int s0/0/0
ip add 172.20.4.10 255.255.255.252
no shutdown
clock rate 64000
router rip
version 2
no auto-summary
network 172.20.254.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y





hostname ISP-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router ISP-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int S0/0/0
ip add 209.165.201.1 255.255.255.252
no shutdown
clock rate 64000
int S0/0/1
ip add 209.165.201.5 255.255.255.252
no shutdown
clock rate 64000
int fa0/0
ip add 209.165.200.225 255.255.255.252
no shutdown
ip route 10.1.0.0 255.255.0.0 s0/0/0
ip route 172.20.0.0 255.255.0.0 s0/0/1
end
copy running-config startup-config
startup-config
reload
y





hostname ISP-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router ISP-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int S0/0/0
ip add 209.165.201.6 255.255.255.252
no shutdown
clock rate 64000
int S0/0/1
ip add 209.165.201.9 255.255.255.252
no shutdown
clock rate 64000
int fa0/0
ip add 209.165.200.229 255.255.255.252
no shutdown
ip route 10.1.0.0 255.255.0.0 s0/0/1
ip route 172.20.0.0 255.255.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y

1 comment:

  1. Dear, i wanna ask :
    on B3-R1 Router

    why the network you entered 10.1.252.1 ?
    -------------------
    router eigrp 1
    no auto-summary
    network 10.1.252.1
    --------------------

    shouldn't it be summarized network = 10.1.48.0 ?? i hope you could help by giving explanation

    many thank's :)

    ReplyDelete