Saturday, June 26, 2010

5.7.1 scripts

hostname R1
no ip domain-lookup
enable password cisco
enable secret cisco
banner motd #Welcome to Router R1#
line console 0
password cisco
login
line vty 0
enable password cisco
login
int s0/0/0
ip add 10.1.244.1 255.255.252.0
no shutdown
clock rate 64000
int s0/0/1
ip add 10.1.248.1 255.255.252.0
no shutdown
clock rate 64000
int s0/1/0
ip add 10.1.252.1 255.255.252.0
no shutdown
clock rate 64000
int s0/1/1
ip add 209.165.201.2 255.255.255.252
no shutdown
clock rate 64000
router rip
default-information originate
passive-interface s0/1/1
network 10.1.0.0
ip route 0.0.0.0 0.0.0.0 s0/1/1
end
copy running-config startup-config
startup-config
reload
y


hostname R2
no ip domain-lookup
enable password cisco
enable secret cisco
banner motd #Welcome to Router R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int s0/0/0
ip add 172.20.250.1 255.255.254.0
no shutdown
clock rate 64000
int s0/0/1
ip add 172.20.252.1 255.255.254.0
no shutdown
clock rate 64000
int s0/1/0
ip add 172.20.254.1 255.255.254.0
no shutdown
clock rate 64000
int s0/1/1
ip add 209.165.201.10 255.255.255.252
no shutdown
clock rate 64000
router rip
default-information originate
passive-interface s0/1/1
network 172.20.0.0
ip route 0.0.0.0 0.0.0.0 s0/1/1
end
copy running-config startup-config
startup-config
reload
y



hostname B1-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B1-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.0.1 255.255.252.0
no shutdown
int fa0/1
ip add 10.1.4.1 255.255.252.0
no shutdown
int fa1/0
ip add 10.1.8.1 255.255.252.0
no shutdown
int fa1/1
ip add 10.1.12.1 255.255.252.0
no shutdown
int s0/0/0
ip add 10.1.244.2 255.255.252.0
no shutdown
clock rate 64000
router rip
network 10.1.0.0
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y



hostname B2-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B2-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.16.1 255.255.252.0
no shutdown
int fa0/1
ip add 10.1.20.1 255.255.252.0
no shutdown
int fa1/0
ip add 10.1.24.1 255.255.252.0
no shutdown
int fa1/1
ip add 10.1.28.1 255.255.252.0
no shutdown
int s0/0/0
ip add 10.1.248.2 255.255.252.0
no shutdown
clock rate 64000
router rip
network 10.1.248.2
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y


hostname B3-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B3-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.32.1 255.255.252.0
no shutdown
int fa0/1
ip add 10.1.36.1 255.255.252.0
no shutdown
int fa1/0
ip add 10.1.40.1 255.255.252.0
no shutdown
int fa1/1
ip add 10.1.44.1 255.255.252.0
no shutdown
int s0/0/0
ip add 10.1.252.2 255.255.252.0
no shutdown
clock rate 64000
router rip
network 10.1.252.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y







hostname B1-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B1-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.0.1 255.255.254.0
no shutdown
int fa0/1
ip add 172.20.2.1 255.255.254.0
no shutdown
int fa1/0
ip add 172.20.4.1 255.255.254.0
no shutdown
int fa1/1
ip add 172.20.6.1 255.255.254.0
no shutdown
int s0/0/0
ip add 172.20.250.2 255.255.254.0
no shutdown
clock rate 64000
router rip
network 172.20.250.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y


hostname B2-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B2-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.8.1 255.255.254.0
no shutdown
int fa0/1
ip add 172.20.10.1 255.255.254.0
no shutdown
int fa1/0
ip add 172.20.12.1 255.255.254.0
no shutdown
int fa1/1
ip add 172.20.14.1 255.255.254.0
no shutdown
int s0/0/0
ip add 172.20.252.2 255.255.254.0
no shutdown
clock rate 64000
router rip
network 172.20.252.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y






hostname B3-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B3-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.16.1 255.255.254.0
no shutdown
int fa0/1
ip add 172.20.18.1 255.255.254.0
no shutdown
int fa1/0
ip add 172.20.20.1 255.255.254.0
no shutdown
int fa1/1
ip add 172.20.22.1 255.255.254.0
no shutdown
int s0/0/0
ip add 172.20.254.2 255.255.254.0
no shutdown
clock rate 64000
router rip
network 172.20.254.1
passive-interface fa0/0
passive-interface fa0/1
passive-interface fa1/0
passive-interface fa1/1
end
copy running-config startup-config
startup-config
reload
y





hostname ISP-R1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router ISP-R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int S0/0/0
ip add 209.165.201.1 255.255.255.252
no shutdown
clock rate 64000
int S0/0/1
ip add 209.165.201.5 255.255.255.252
no shutdown
clock rate 64000
int fa0/0
ip add 209.165.200.225 255.255.255.252
no shutdown
ip route 10.1.0.0 255.255.0.0 s0/0/0
ip route 172.20.0.0 255.255.0.0 s0/0/1
end
copy running-config startup-config
startup-config
reload
y





hostname ISP-R2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router ISP-R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int S0/0/0
ip add 209.165.201.6 255.255.255.252
no shutdown
clock rate 64000
int S0/0/1
ip add 209.165.201.9 255.255.255.252
no shutdown
clock rate 64000
int fa0/0
ip add 209.165.200.229 255.255.255.252
no shutdown
ip route 10.1.0.0 255.255.0.0 s0/0/1
ip route 172.20.0.0 255.255.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y

6 comments:

  1. I do not understand how R1 is getting assigned 10.1.224.0, 10.1.248.0, 10.1.252.0 as an address space. I know the directions say the LAST 3 subnets to these interfaces on R1 but I still do not understand why it is those specifically.
    Using the calculation to find out how many total subents could be created with this subnet mask, then there should be 16,384 subnets which would mean that 244, 248 and 252 are not the 'last' subnets then.

    How are they getting these last three addresses then, the 244, 248 and 252?
    Please help me to understand!

    ReplyDelete
    Replies
    1. there are only 1000 hosts needed, so you use /22 subnet class B with 1024 hosts, the last 3 subnets are 244,248 and 252.
      so you use subnet 255.255.252.0

      Delete
  2. and what are the commands of the web servers?

    ReplyDelete
  3. Can i have the Answer of Activity 6.5.1: Packet Tracer Skills Integration challenge Activity

    ReplyDelete