Monday, June 28, 2010

11.6.2 Scripts

hostname HQ
no ip domain-lookup
banner motd #Welcome to Router HQ#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.0.1 255.255.224.0
no shutdown
int s0/0/0
ip add 172.20.56.1 255.255.255.252
no shutdown
clock rate 64000
bandwidth 64
int s0/0/1
ip add 172.20.56.5 255.255.255.252
no shutdown
clock rate 64000
int loopback1
ip add 10.10.10.1 255.255.255.252
router ospf 1
default-information originate
passive-interface fa0/0
ip route 0.0.0.0 0.0.0.0 loopback1
end
copy running-config startup-config
startup-config
reload
y




hostname Branch1
no ip domain-lookup
banner motd #Welcome to Router Branch 1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.32.1 255.255.240.0
no shutdown
int s0/0/0
ip add 172.20.56.2 255.255.255.252
no shutdown
clock rate 64000
bandwidth 64
int s0/0/1
ip add 172.20.56.9 255.255.255.252
no shutdown
clock rate 64000
bandwidth 64
router ospf 1
passive-interface fa0/0
end
copy running-config startup-config
startup-config
reload
y




hostname Branch 2
no ip domain-lookup
banner motd #Welcome to Router Branch 2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.20.48.1 255.255.248.0
no shutdown
int s0/0/0
ip add 172.20.56.10 255.255.255.252
no shutdown
clock rate 64000
int s0/0/1
ip add 172.20.56.6 255.255.255.252
no shutdown
clock rate 64000
router ospf 1
passive-interface FastEthernet0/0
end
copy running-config startup-config
startup-config
reload
y

7 comments:

  1. This is awsome thankyou, but could you give us the config for the 3 pc devices that are connected

    ReplyDelete
  2. PC1-172.20.31.254 255.255.240.0 gate-172.20.32.1
    PC2-172.20.31.254 255.255.224.0 gate-172.20.0.1
    PC3-172.20.55.254 255.255.248.0 gate-172.20.48.1

    ReplyDelete
    Replies
    1. This comment has been removed by the author.

      Delete
  3. Hey, 1st adress of 172.20.0.0 /19 subnet is 172.20.1.0 no ? why 172.20.0.1 ?

    ReplyDelete
  4. The lab book uses different bandwidths than you listed. In the manual each connection is a different bandwidth. B1 - HQ: 128 kbs. HQ - B2: 256 kbps. B2 - B1: 64 kbps. You used 64 for all the connections. The system works, either way, but the answers to Task 11 are dependent of having different bandwidths.

    ReplyDelete
  5. Mucha ayuda en general, mushisimas gracias

    ReplyDelete