Saturday, June 26, 2010

9.6.1 Scripts

hostname R1
no ip domain-lookup
banner motd #Welcome to Router R1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.16.1.1 255.255.255.0
no shutdown
int s0/0/0
ip add 172.16.3.1 255.255.255.252
no shutdown
clock rate 64000
bandwidth 64
int s0/0/1
ip add 192.168.10.5 255.255.255.252
no shutdown
clock rate 64000
router eigrp 1
no auto-summary
network 192.168.10.4 0.0.0.3
network 172.16.0.0
passive-interface fa0/0
end
copy running-config startup-config
startup-config
reload
y




hostname R2
no ip domain-lookup
banner motd #Welcome to Router R2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.16.2.1 255.255.255.0
no shutdown
int s0/0/0
ip add 172.16.3.2 255.255.255.252
no shutdown
clock rate 64000
bandwidth 64
int s0/0/1
ip add 192.168.10.9 255.255.255.252
no shutdown
clock rate 64000
bandwidth 64
int loopback0
ip add 10.1.1.1 255.255.255.252
router eigrp 1
no auto-summary
network 192.168.0.0
network 172.16.0.0
passive-interface fa0/0
end
copy running-config startup-config
startup-config
reload
y




hostname R3
no ip domain-lookup
banner motd #Welcome to Router R3#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 192.168.1.1 255.255.255.0
no shutdown
int s0/0/0
ip add 192.168.10.6 255.255.255.252
no shutdown
clock rate 64000
int s0/0/1
ip add 192.168.10.10 255.255.255.252
no shutdown
clock rate 64000
end
copy running-config startup-config
startup-config
reload
y





hostname B1
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B1#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.32.1 255.255.255.0
no shutdown
int fa0/1
ip add 10.1.33.1 255.255.255.0
no shutdown
int s0/0/0
ip add 172.20.0.2 255.255.255.252
no shutdown
clock rate 64000
ip summary-address eigrp 1 10.1.32.0 255.255.254.0
int s0/0/1
ip add 172.20.0.13 255.255.255.252
no shutdown
ip hello-interval eigrp 1 60
ip summary-address eigrp 1 10.1.32.0 255.255.254.0
bandwidth 64
clock rate 64000
router eigrp 1
no auto-summary
passive-interface fa0/0
passive-interface fa0/1
network 172.20.0.0
network 10.1.0.0
ip route 0.0.0.0 0.0.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y





hostname B2
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B2#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.34.1 255.255.255.128
no shutdown
int fa0/1
ip add 10.1.34.129 255.255.255.128
no shutdown
int s0/0/0
ip add 172.20.0.6 255.255.255.252
no shutdown
clock rate 64000
ip summary-address eigrp 1 10.1.34.0 255.255.255.0
int s0/0/1
ip add 172.20.0.14 255.255.255.252
no shutdown
clock rate 64000
bandwidth 64
ip hello-interval eigrp 1 60
ip summary-address eigrp 1 10.1.34.0 255.255.255.0
int s0/1/0
ip add 172.20.0.17 255.255.255.252
no shutdown
bandwidth 64
ip hello-interval eigrp 1 60
clock rate 64000
ip summary-address eigrp 1 10.1.34.0 255.255.255.0
router eigrp 1
no auto-summary
network 10.1.0.0
network 172.20.0.0
passive-interface fa0/0
passive-interface fa0/1
ip route 0.0.0.0 0.0.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y






hostname B3
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router B3#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.1.35.1 255.255.255.192
no shutdown
int fa0/1
ip add 10.1.35.65 255.255.255.192
no shutdown
int s0/0/0
ip add 172.20.0.10 255.255.255.252
no shutdown
clock rate 64000
ip summary-address eigrp 1 10.1.35.0 255.255.255.128
int s0/0/1
ip add 172.20.0.18 255.255.255.252
no shutdown
clock rate 64000
ip summary-address eigrp 1 10.1.35.0 255.255.255.128
bandwidth 64
ip hello-interval eigrp 1 60
router eigrp 1
no auto-summary
network 10.1.0.0
network 172.20.0.0
passive-interface fa0/0
passive-interface fa0/1
ip route 0.0.0.0 0.0.0.0 s0/0/0
end
copy running-config startup-config
startup-config
reload
y








ip summary-address eigrp 1 10.1.35.128 255.255.255.192
int s0/1/0
ip add 172.20.0.5 255.255.255.252
no shutdown
clock rate 64000
ip summary-address eigrp 1 10.1.35.128 255.255.255.192
int s0/1/1
ip add 172.20.0.9 255.255.255.252
no shutdown
clock rate 64000
ip summary-address eigrp 1 10.1.35.128 255.255.255.192
router eigrp 1
no auto-summary
network 10.1.0.0
network 172.20.0.0
passive-interface fa0/0
passive-interface fa0/1
passive-interface s0/0/0
ip route 0.0.0.0 0.0.0.0 s0/0/0

1 comment: