Saturday, June 26, 2010

5.6.3 Scripts

hostname BRANCH
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router Branch#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 192.168.1.1 255.255.255.0
no shutdown
int s0/0/0
clock rate 64000
ip add 10.45.1.254 255.255.255.0
no shutdown
router rip
network 10.45.1.0
network 192.168.1.0
end
copy running-config startup-config
startup-config
reload
y




hostname HQ
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router HQ#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 10.45.2.1 255.255.255.0
no shutdown
int s0/0/0
ip add 10.45.1.1 255.255.255.0
no shutdown
clock rate 64000
int s0/0/1
ip add 172.20.20.254 255.255.255.0
no shutdown
clock rate 64000
router rip
default-information originate
passive-interface fa0/0
end
copy running-config startup-config
startup-config
reload
y



hostname ISP
no ip domain-lookup
enable password cisco
banner motd #Welcome to Router ISP#
line console 0
password cisco
login
line vty 0
password cisco
login
int fa0/0
ip add 172.16.1.1 255.255.255.0
no shutdown
int s0/0/1
ip add 172.20.20.1 255.255.255.0
no shutdown
clock rate 64000
ip route 10.45.0.0 255.255.255.0 s0/0/1
end
copy running-config startup-config
startup-config
reload
y

2 comments:

  1. This is only bringing me to 80% where's the rest?

    ReplyDelete
  2. is no rest because at ISP the subnet mask it isn't 255.255.255.0


    It is 255.255.252.0

    ReplyDelete